Can't start snmpd when adding notification handler to the configuration file

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't start snmpd when adding notification handler to the configuration file

An Le Thien
Hi,

I have a problem when starting snmpd as following:

1. I have just downloaded net-snmp-5.0.6-17_2.src.rpm from ftp://ftp.sunet.se/pub/Linux/distributions/eldk/3.1.1/ppc-linux-x86/sources/target/SRPMS/

2. I used ELDK3.1.1 to build it and install to ramdisk that is used for TQM8xxL (Using kernel 2.6.11)

3. I used the default configuration ( EXAMPLE.conf). When I started snmpd, the snmpd was started normally.

4. But when I add "trapsink 192.168.1.15 public" to the configuration file. I can't start snmpd. The following is the configuration file and a log file:

a.  /etc/snmp/snmpd.conf

trapsink 192.168.1.15 public
com2sec local     localhost       public
com2sec mynetwork 192.168.1.0/24      public
......

b. /var/log/snmpd.log

.....
snmp_clean_persistent:  removing old config file: /var/net-snmp/snmpd.0.conf
trace: snmp_call_callbacks(): callback.c, 99
callback: START calling callbacks for maj=1 min=7
trace: snmp_call_callbacks(): callback.c, 107
callback: calling a callback for maj=1 min=7
trace: send_notifications(): notification/snmpNotifyTable.c, 95
send_notifications: starting: pdu=1009abe8, vars=7fffe37c
segmentation faults


Could you give some comments to fix this problem?

Thanks in advance.

An Le.

_______________________________________________
Linuxppc-embedded mailing list
[hidden email]
https://ozlabs.org/mailman/listinfo/linuxppc-embedded
wd
Reply | Threaded
Open this post in threaded view
|

Re: Can't start snmpd when adding notification handler to the configuration file

wd
In message <[hidden email]> you wrote:
>
> 2. I used ELDK3.1.1 to build it and install to ramdisk that is used for
> TQM8xxL (Using kernel 2.6.11)

ELDK 3.x has been tested with  2.4  kernel  trees  only.  For  a  2.6
kernel, you should use ELDK 4.x.

Best regards,

Wolfgang Denk

--
Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: [hidden email]
Hiring experienced unix people is  like  a  built-in  filter  against
idiots. Hiring experienced NT people provides no such guarantee.
            -- Miguel Cruz in WgL96.349$[hidden email]
_______________________________________________
Linuxppc-embedded mailing list
[hidden email]
https://ozlabs.org/mailman/listinfo/linuxppc-embedded
Reply | Threaded
Open this post in threaded view
|

Re: Can't start snmpd when adding notification handler to the configuration file

An Le Thien
I tried to download net-snmp-5.2.1.2-1_1.src.rpm of ELDK4.0 and  used ELDK4.0  to build. But the same error happens :(. Then I tried to build net-snmp-5.0.6-17_2.src.rpm with ELDK4.0. The error still happens.

Best Regards,
An Le.

On 1/11/07, Wolfgang Denk <[hidden email]> wrote:
In message <[hidden email]> you wrote:
>
> 2. I used ELDK3.1.1 to build it and install to ramdisk that is used for
> TQM8xxL (Using kernel 2.6.11)

ELDK 3.x has been tested with   2.4  kernel  trees  only.  For  a  2.6
kernel, you should use ELDK 4.x.

Best regards,

Wolfgang Denk

--
Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: [hidden email]
Hiring experienced unix people is  like  a  built-in  filter  against
idiots. Hiring experienced NT people provides no such guarantee.
            -- Miguel Cruz in [hidden email]


_______________________________________________
Linuxppc-embedded mailing list
[hidden email]
https://ozlabs.org/mailman/listinfo/linuxppc-embedded