[PATCH] powerpc/configs: fix default values for NF_CT_PROTO_*

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[PATCH] powerpc/configs: fix default values for NF_CT_PROTO_*

Davide Caratti
NF_CT_PROTO_{SCTP,UDPLITE,DCCP} can't be set to 'm' anymore, since they
have been redefined as 'bool': fix defconfig for linkstation, mvme5100 and
ppc6xx platforms accordingly.

Signed-off-by: Davide Caratti <[hidden email]>
---
 arch/powerpc/configs/linkstation_defconfig | 2 +-
 arch/powerpc/configs/mvme5100_defconfig    | 2 +-
 arch/powerpc/configs/ppc6xx_defconfig      | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/configs/linkstation_defconfig b/arch/powerpc/configs/linkstation_defconfig
index b413c19..d36d618 100644
--- a/arch/powerpc/configs/linkstation_defconfig
+++ b/arch/powerpc/configs/linkstation_defconfig
@@ -26,7 +26,7 @@ CONFIG_IP_PNP_BOOTP=y
 # CONFIG_IPV6 is not set
 CONFIG_NETFILTER=y
 CONFIG_NF_CONNTRACK=m
-CONFIG_NF_CT_PROTO_SCTP=m
+CONFIG_NF_CT_PROTO_SCTP=y
 CONFIG_NF_CONNTRACK_AMANDA=m
 CONFIG_NF_CONNTRACK_FTP=m
 CONFIG_NF_CONNTRACK_H323=m
diff --git a/arch/powerpc/configs/mvme5100_defconfig b/arch/powerpc/configs/mvme5100_defconfig
index 139add9..265ccec 100644
--- a/arch/powerpc/configs/mvme5100_defconfig
+++ b/arch/powerpc/configs/mvme5100_defconfig
@@ -35,7 +35,7 @@ CONFIG_IP_PNP_BOOTP=y
 # CONFIG_IPV6 is not set
 CONFIG_NETFILTER=y
 CONFIG_NF_CONNTRACK=m
-CONFIG_NF_CT_PROTO_SCTP=m
+CONFIG_NF_CT_PROTO_SCTP=y
 CONFIG_NF_CONNTRACK_AMANDA=m
 CONFIG_NF_CONNTRACK_FTP=m
 CONFIG_NF_CONNTRACK_H323=m
diff --git a/arch/powerpc/configs/ppc6xx_defconfig b/arch/powerpc/configs/ppc6xx_defconfig
index 18d0d60..bc8ff4b 100644
--- a/arch/powerpc/configs/ppc6xx_defconfig
+++ b/arch/powerpc/configs/ppc6xx_defconfig
@@ -141,7 +141,7 @@ CONFIG_NETFILTER=y
 CONFIG_NF_CONNTRACK=m
 CONFIG_NF_CONNTRACK_SECMARK=y
 CONFIG_NF_CONNTRACK_EVENTS=y
-CONFIG_NF_CT_PROTO_UDPLITE=m
+CONFIG_NF_CT_PROTO_UDPLITE=y
 CONFIG_NF_CONNTRACK_AMANDA=m
 CONFIG_NF_CONNTRACK_FTP=m
 CONFIG_NF_CONNTRACK_H323=m
--
2.9.4

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [PATCH] powerpc/configs: fix default values for NF_CT_PROTO_*

Michael Ellerman-2
Davide Caratti <[hidden email]> writes:

> NF_CT_PROTO_{SCTP,UDPLITE,DCCP} can't be set to 'm' anymore, since they
> have been redefined as 'bool': fix defconfig for linkstation, mvme5100 and
> ppc6xx platforms accordingly.

Since when? ie. which commit changed the symbols to bool from tristate?

cheers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [PATCH] powerpc/configs: fix default values for NF_CT_PROTO_*

Davide Caratti
On Tue, 2017-06-13 at 20:49 +1000, Michael Ellerman wrote:
> Davide Caratti <[hidden email]> writes:
>
> > NF_CT_PROTO_{SCTP,UDPLITE,DCCP} can't be set to 'm' anymore, since they
> > have been redefined as 'bool': fix defconfig for linkstation, mvme5100 and
> > ppc6xx platforms accordingly.
>
> Since when? ie. which commit changed the symbols to bool from tristate?
>
> cheers

hello Michael,

the commits are:

a85406afeb3e ("netfilter: conntrack: built-in support for SCTP")
c51d39010a1b ("netfilter: conntrack: built-in support for DCCP")
9b91c96c5d1f ("netfilter: conntrack: built-in support for UDPlite")

they were causing a "warning symbol value 'm' invalid" in kconfig: sorry
for not noticing this before. I see that ARM and MIPS already have a fix:

5aff1d245e8c ("ARM: defconfigs: make NF_CT_PROTO_SCTP and
NF_CT_PROTO_UDPLITE built-in")
9ddc16ad8e0b ("MIPS: Update defconfigs for NF_CT_PROTO_DCCP/UDPLITE
change")

but (some) ppc and tile defconfig were still missing the correction:
that's why I submitted this patch (and a similar one, http://www.mail-arch
ive.com/[hidden email]/msg1413473.html , for tile).

thank you for looking at this,
regards
--
davide






Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [PATCH] powerpc/configs: fix default values for NF_CT_PROTO_*

Michael Ellerman-2
Davide Caratti <[hidden email]> writes:

> On Tue, 2017-06-13 at 20:49 +1000, Michael Ellerman wrote:
>> Davide Caratti <[hidden email]> writes:
>>
>> > NF_CT_PROTO_{SCTP,UDPLITE,DCCP} can't be set to 'm' anymore, since they
>> > have been redefined as 'bool': fix defconfig for linkstation, mvme5100 and
>> > ppc6xx platforms accordingly.
>>
>> Since when? ie. which commit changed the symbols to bool from tristate?
>
> hello Michael,
>
> the commits are:
>
> a85406afeb3e ("netfilter: conntrack: built-in support for SCTP")
> c51d39010a1b ("netfilter: conntrack: built-in support for DCCP")
> 9b91c96c5d1f ("netfilter: conntrack: built-in support for UDPlite")
>
> they were causing a "warning symbol value 'm' invalid" in kconfig: sorry
> for not noticing this before.

No worries. Thanks for sending the fix.

My auto builder did hit the warning, but it doesn't fail for those
warnings, eg:

http://kisskb.ellerman.id.au/kisskb/buildresult/13060278/


I'm actually going through our configs at the moment so I'll add this to
that series and merge it for 4.13.

cheers
Loading...